Google Cloud Platform currently experiencing issues

Incident Report for Aiva Health

Resolved

Google Cloud Platform incident is now resolved. The issue lasted from approximately 11 am to 1:10 pm PST.
Posted Jun 12, 2025 - 15:43 PDT

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 12:24 PDT